Reply
New Contributor
Isylwin
Posts: 1
0

Unable to ping own hamachi ip

Hi,

 

I've been trying to ping myself and another computer but it just wont work. I've been able earlier today to ping my own IP, but not my friends. Now my friend can ping me but I cant ping myself nor him. I've tried everything I've found on the internet, disabling my firewall, making hamachi a private network, public network, rearranging network priority, ICMP, disabling NAT, restarting my computer, forwarding ports, reinstalling hamachi, but nothing so far has changed the message I keep getting while trying to ping myself: "Answer from 5.127.xxx.xxx: Target host can not be reached (Operating system is in dutch so I just translated it, I have no idea what the message is on english comps).

 

If anyone has any suggestions on how to tackle this, please tell me.

New Contributor
gerrytan
Posts: 1
0

Re: Unable to ping own hamachi ip

Hi, this might be due to windows firewall blocking the ping (ICMP) protocol. I manage to ping windows remote host connected via hamachi by allowing it through the firewall. Following are the steps for windows 7 (should be similar for other windows version):

 

1. Go to control panel -> windows firewall

2. Add a new inbound rule, select 'custom'

3. Select 'rule applies to all programs'

4. Select protocol type 'ICMPv4'

5. Just accept the default and hit next for remaining settings

 

Once you have the rule configured, try pinging your remote host again.

New Contributor
shasty
Posts: 2
0

Re: Unable to ping own hamachi ip

I have the same/similar problem.  I've been using Hamachi for several years, and just recently I've been unable to ping/RDC or otherwise connect from my work to my home PC.   I have 5 machines on the mesh network.  It just started out of the blue.

 

From my home PC, I can ping/browse all other machines except the work PC.  From my work PC, I can ping/browse all other machines except the home PC.  Only affects the tunnel between work and home PC.

 

Does not appear to be a firewall rule, because this morning I was successully connected to my home PC from work via Remote Desktop Connection and Hamachi.  Later in the morning, it was showing my home PC offline.

 

No changes have been made to the firewall on either of the affected machines, and it's strange that it worked for a period of time this morning, but now doesn't again. 

 

I have reinstalled Hamachi client on both machines, but it doesn't seem to have made a difference.

 

Is this a bug in Hamachi?  Any help would be appreciated.

New Contributor
JohnLammers
Posts: 1
0

Re: Unable to ping own hamachi ip

Just wanted to chime in, lest this get written off as one guy's problem.  I have a very similar situation.  Everything was working fine for me with Hamachi, at home and work, for about a year, and then it just stopped working, both between computers in my home and between computers at work and between home and work. I can't swear that no one has changed the work environment, though that seems unlikely, but I know I havent' changed the home environment.  Every machine in my 6 machine cluster is affected.  By "not working" I mean no ping, not RDP. I also have tried the permissive firewall changes that I've read about online, including turning off Windows Firewall completely, but to no avail.

New Contributor
schuc
Posts: 2
0

Re: Unable to ping own hamachi ip

+1 for me

 

I am not fully down though.  I have a 5 PC mesh and two machines are able to ping and RDC back and forth.  The others do not respond to ping or RDC.  I really got Hamachi for the RDC vpn and not sharing local resources, so this is a big issue for me.

 

I will keep following this thread to see if something useful is suggested and/or discovered as the discussion continues.

 

Thanks for all who are trying to help

New Contributor
schuc
Posts: 2
0

Re: Unable to ping own hamachi ip

Well, good news on my side.  I will explain what I discovered and I hope it may help a few of you as well.

 

From reading some other threads, I saw that some were having issues with Kaspersky or maybe even just Windows having your network in the wrong zone.  It should not be in the Public zone.

 

Kaspersky Internet Security 2011:  http://support.kaspersky.com/4136

Kaspersky Internet Security 2012:  http://support.kaspersky.com/6423

 

This wasn't the issue for me, but I wanted to share that since it seemed to help some others.  For me, I was running an applicaton called PeerBlock that is used to block unwanted traffic.  Clearly, the 25.* range is not in the whitelists that are loaded so it was being blocked.  Adding the computers in my mesh has straightened things out.  I can now RDC to the system via the Hamachi IP.

 

I hope this helps!

New Contributor
shasty
Posts: 2
0

Re: Unable to ping own hamachi ip

Thanks for the advice.  I had tried changing the zone on my Win7 PC to no avail.  Strangely enough, I have not had the issue since about a week after my last post.  No changes on my end.  I'm guessing it's a hamachi issue.

Contributor
a1phageek
Posts: 8
0

Re: Unable to ping own hamachi ip

Solved:

Use the following method to change the network type of connection from Public to Private.

Set Network to be Private in Windows 8 and 8.1 in Registry

1.Press Win + R keys to open the Run dialog, type regedit, and press Enter.

2.In Registry Editor, navigate to the location below:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles

3.Expand Profiles, click on each long GUID number subkey, and look at its PofileName string value in the right pane to see if it has the current network name (ex: Network) until found.

4.When you find the correct PofileName for your network name, double click/tap on the Category DWORD value in the same right pane to modify it.

5.Type in a new Data value number for the network location you want, and click/tap on OK.

Network location      Data value

Public                                0

Private                             1

Domain                            2

6.When finished, please reboot your computer.