Reply
Active Contributor
vlad0
Posts: 2
0

Re: Hamachi 1 & 2 both cause Default Gateway conflict under Win7

Hi All!

First post in this forum.

I have also come across the same problem. And was searching the internet and found this topic, but only I after I have fixed the problem.

So here is the fix.

 

The reason for this problem is Hamachi added a persistent route to 0.0.0.0 (Default route) via 5.0.0.1/8 for no apparent reason.

 

It can be seen if you run route print command in the cmd prompt.

If you get rid of this route by command route delete -p 0.0.0.0 the problem disappears. (Run CMD as administrator, otherwise Vista or 7 won't let you do it.)

 

As it was mentioned above the windows stops treating Hamachi interface as a private network and reassigns it as Public, but I am happy with this as long as my wireless internet connection doesn't drop every 10 minutes.

 

 

New Contributor
duanes1967
Posts: 1
0

Re: FIX Hamachi 1 & 2 both cause Default Gateway conflict under Win7

FIX

 

STILL a problem - WTH, does anyone is Hamachi support ever watch the forums?

 

You must run this every time Hamachi updates.... or you might set it to run at every boot.  On my system, the offending route is 5.0.0.1.  You might need to adjust the command below if your's is different.  To see the routes, type "route print" at the command line.  It will be one of the first two lines under "IPv4 Route Table".  It is the one with the large number on the last column under "Metric".  Your correct gateway will be listed with a small number under metric.

 

Normally, the Hamachi route will not cause any problems, but if something happens to your normal router or there is a hichup or delay, Windows may switch to the "Backup" default route.  That is where the problem lies.  I have NO IDEA why Hamachi needs or wants a default route entry.  This really looks like the work of a routing amatuer.... although, there may be some deep, dark routing voodoo going on.

 

As far as I can tell, this does NOT affect Hamachi operation or usability.

Do this FIX from the ADMINISTRATOR command line-

 

route delete 0.0.0.0 mask 0.0.0.0 5.0.0.1

 

 

New Contributor
Spurch
Posts: 1
0

Re: FIX Hamachi 1 & 2 both cause Default Gateway conflict under Win7

I have never experienced this issue other than once when I first installed Hamachi it set the metrics incorrectly.  Changed the metrics on my default nic to 100 and the metrics on the hamachi adapter to 9000 and never had another issue and it was a crappy nic with a crappy driver.

 

If your router is not providing proper settings for the local gateway I could see this being an issue but I never connect my computer directly to the modem, always through a router that I configure myself.

 

My gateway (DHCP providing router) is solid and doesn't time out on me causing the computer to look to the next connection type for the gateway route.

 

And no, this is not a forum that is monitored by Tech Support.  This is a "Community" site that allows us all to post and try to help each other.  You want support?  Post a ticket if you are using the free version, if you are a paid customer call them.

 

Most folks who use hamachi as a "Gateway" network don't do it correctly and put it on a Windows workstation computer that is NOT a Server. The Gateway configuration is designed to be done on a server so it can route the host domain's DHCP/DNS/Exchange info and use the host domain's IP ranges and even limit internet access to the hamachi bridge so as to secure the network locally and not allow multi-homed clients to potentially allow outside traffic into the domain.

 

(Not that this is the case, just an observance.)

 

If you want "support" create a ticket online, this is a place to share data and help your fellow VPN/Hamachi users.

 

Good luck! :smileyhappy:

 

/2cents off.

New Contributor
zachiew
Posts: 1
0

Re: Hamachi 1 & 2 both cause Default Gateway conflict under Win7

To fix this issue, do the following.

 

1. Uninstall Hamachi, ensure that everything is gone, do NOT preserve user history.

 

2. Physically remove all network connection to your computer (unplug network cable)

 

3. Restart your computer.

 

4. Connect network cable for your router to your computer.

 

5. Install Hamachi

 

and this should work.

 

You should see the "fresh install" 0.0.0.0 screen asking you to hit the Power button.

 

If you don't see that, try to find all Hamachi files and delete them before doing another install of Hamachi.

 

6. Run command prompt and type "route print"

 

You should see that your route maps as below

 

Network Destination     Netmask    Gateway       Interface         Metric

0.0.0.0                       0.0.0.0      192.168...    192.168....      Some value here

0.0.0.0                       0.0.0.0      5.0.0.1         5..........         Some value here

New Contributor
Swing_Chef
Posts: 2
0

Re: FIX Hamachi 1 & 2 both cause Default Gateway conflict under Win7

So, I resurrected this thread once before (after a year) because I was frustrated, and still seeing issues on a regular basis.  This time, I may have a better solution.  Below are some of the associated points:

- From what I've read, Hamachi creates a default gateway entry on your client because Windows 7 requires a default gateway for all private networks.  If you "route delete" the 0.0.0.0 address, it will change your Hamachi network to a "public" network and make the necessary security/firewall changes.

- Don't confuse "default network gateway" with "Hamachi Gateway network".  I see the gateway problem on my "Mesh" network.  I've never actually used the "Gateway Network" configuration, so I'm pretty I'm not misusing Hamachi's Gateway network functionality.

- Since NT 3.5 are newer, Windows has utilized a "Dead Gateway" detection algorythm that uses TCP/IP traffic to determine that a Gateway is dead.  Once it decides that the gateway is dead, it switches to using a secondary gateway (in this case, the hamachi gateway that doesn't actually work if the main gateway dies).  The kicker is that as far as I have read, Windows does not switch back when the original Gateway comes back on-line.

 

Solution?

According to the Microsoft article below, there is a registry key within

"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters"

that allows you disable the automatic detection (and fallback).  On my Windows 7 Ultimate laptop, it looks like the key is "DeadGWDetectDefault".  I changed the Value of this key to "0".  I don't have any multihomed machines, so I don't believe that I use the backup gateway functionality.  I haven't seen any problems with my connection thus far.  If you don't see me post here in the next year (or so) :), perhaps I found a way to get around this.

 

Microsoft article on Dead Gateway Connection: http://support.microsoft.com/kb/128978